主页  »  技术支持  »  FAQ
IDM Computer Solutions frequently asked questions

IDM 常见问题解答

如果您在这里没有看见您的问题,并且您无法找到答案,请到我们的使用技巧查找,或者使用搜索,或者请把您的问题发电子邮件给我们。

点击下面问题展开答案

Show all  Hide all

我是否需要在安装更新或升级之前卸载UltraEdit?

建议:不用卸载UltraEdit,只要覆盖现有的安装文件。 这将维护您当前INI设置。 您将被提示是否或不希望覆盖您的wordfile。 如果您wordfile被覆盖并且假如您以后希望使用您的旧wordfile,请将它改名为wordfile.old。

我怎么可以下载UltraEdit以前的或旧的版本?

对UltraEdit的老版本(并且UEStudio、UltraCompare和UltraSentry)仅可通过电子邮件获得。 请给我们发电子邮件support@ultraedit.cn,并且需要您当前最新的注册信息,我们将提供给您符合条件的版本。

为什么会安装中断或不工作?

首先,请务必确信您解压的所有来自ZIP安装文件到您的计算机硬盘上的一个实际文件夹。

Ghost 安装程序使用以前的安装程序依靠Internet Explorer 6相关的DLLs。 当发布了Internet Explorer 7,这些DLLs不再是可利用的,造成老版本有些安装程序根本不起作用。

如果您使用IE7,并且您的安装程序不工作,请给我们发带有您的当前注册信息的电子邮件到support@ultraedit.cn,因此我们可以协助您解决这个问题。

我怎么能使用UltraEdit删除空行?

为了能删除在DOS/Unix/Mac格式文件中的空行, 请使用下面兼容的Perl规则表达式。在高级 -> 配置 -> 搜索 -> 规则表达式引擎,您能允许兼容Perl规则表达式。

替换: "^\r?\n?$" (没有引号)
关于 "" (没有引号).

UltraEdit更早的版本:

要删除带DOS行命令终端的空白行,您能使用UltraEdit样式规则表达式替换如下:

替换: "^p$" (没有引号)
关于 "" (没有引号).

运行替换直到每个空行被删除。

我怎么可以在UltraEdit中删除带空白制表符/空格的空行?

要删除带空白制表符/空格的空行,您能使用一个Perl兼容的规则表达式替换如下:

替换: "\n\s*\r" (没有双引号)
With "" (without the quotes - i.e. nothing).

这应该带空白制表符/空格的全部空行被替换,除了您会需要手动地删除最后一行。

为什么删除行尾部的空白部分(Trim Trailing Spaces)在文件的最后行不起作用?

Trim Trailing Spaces(删除行尾部的空白部分)的功能是它要求换行符在特定文本行起作用。如果在您文件里最后文本行被强行返回中断,Trim Trailing Spaces将那行起作用。

UltraEdit为什么一直问我是否想要转换Unix文件成DOS ?

By default the file is recognized as UNIX or MAC and the status bar should show this. When the file is loaded it will be converted to DOS (CR/LF) and in HEX mode you will see this as 0D 0A. When the file is saved it will be converted back to UNIX (LF only) if the "Save file as input format" setting is set in Advanced -> Configuration.

The settings in Advanced -> Configuration default to the above actions.

If you go to Advanced -> Configuration -> File Handling -> DOS/UNIX/MAC Handling and choose "Disable" for the "Unix/Mac file detection/conversion" setting this will not happen, or you can leave it set and if you want the file saved as DOS format you can disable the setting "Save file as input format".

Additionally the file may be manually converted from the File menu. When converted to UNIX or MAC from the file menu the actual conversion takes place when the file is saved but the status bar is updated immediately so that you are aware of the format.

我点击“是”对转换提示从UNIX/MAC到DOS转换,当我打开文件时,文件转换似乎不完全工作或根本不工作。 这为什么会发生?

UltraEdit only converts the file if it is edited and then saved. Also, if you have "Save file as input format" selected in the Advanced configuration menu, the conversion is overridden on save.

The primary purpose behind the automatic/dialog-prompt conversion on file open is to allow the Windows clipboard to function properly. With conversion enabled, a copy or cut operation will include DOS line endings (0D 0A), which allows for seamless use of UNIX/MAC files in a DOS environment. The easiest way to get intuitive behavior is to disable the "Save file as input format" option.

我怎么能配置UltraEdit仅创建Unix格式文件?

Version 11.20 and later:

You can access this setting by going to Advanced -> Configuration -> File Handling -> DOS/UNIX/MAC Handling. Select "UNIX" as the "Default file type for new files".

Prior to v11.20:

There is a DOS/UNIX/MAC Handling topic under the File Handling branch under Configuration in the Advanced menu to allow specification of the default format for new files created in UltraEdit. Under "Default file type for new files" you may select either "DOS", "UNIX", or "MAC" and new files would be created with the appropriate line terminators.

我怎么可以禁止提示打开文件没有临时文件?

By default a confirmation dialog is shown when editing files without a temporary file as there is no backup made and all changes are permanent. If you wish you may disable this under the Temporary Files topic in the File Handling branch under Configuration in the Advanced menu by selecting "Open file without temp file but NO Prompt".

几乎每次在我打开文件时候,我看这则消息: “为了正确地显示文档,您可以必须改变您的在字体对话框中的字体和/或脚本设置”。 我怎么可以永久地去掉?

This prompt is related to your font and script settings and the codepage you are using. You can disable this prompt by going to Advanced -> Configuration -> File Handling -> Code Page Detection. Uncheck the option "Prompt to change font and script if different from default system codepage".

我怎么在UltraEdit里做多行的查找或替换?

Version 14 of UltraEdit and 06.50 of UEStudio include a new multiline find and replace dialog.

Prior to these versions:

You can do this using "^p" as the CR/LF - UltraEdit translates the ^p into a hard return. You can also use the contents of the clipboard or selected text in a search or replace string with "^c" and "^s" respectively. You can copy/select a string up to 1000 bytes for use this way.

为什么查找下一个(F3)不能查找被选择的或被高亮的文本,虽然相应配置被设置?

Usually when users see this behavior it is because the "Regular Expressions" checkbox has been left checked in the Search -> Find dialog box.

By design, UltraEdit will not search for a highlighted word when "Regular Expressions" has been left checked in this dialog. Instead, with "Regular Expressions" checked, UltraEdit will search for the last string entered into the "Find What" dialog.

我怎么可以在UltraEdit启动时始终创建一个新的空白文件?

Please go to Advanced -> Configuration -> Editor -> New File Creation and ensure that "Create new EDIT file when opening with no other files" is not selected.

我怎么可以修改文件类型列表,在文件- >打开对话框?

Click on Configuration in the Advanced menu and click on the File Types branch/tab. This page allows the list of file types that appear in the File Open and File Save As dialog boxes to be configured. Up to 10 file types may be configured. The first extension for these file types will be shown in the file operation dialog boxes in the same order they are shown on this page.

FTP文件为什么没有重载一个项目?

Reloading of FTP files is not enabled by default due to the time it can take to download files via FTP. However, if you do want UltraEdit-32 to do this, please go to Advanced -> Configuration -> File Handling -> Load and select "Reload FTP files when reloading a project or last open files".

为什么需要很长时间打开有些系统的大文件?

Regarding large files, UltraEdit handles files in excess of 4GB. UltraEdit is disk based. This means it only loads small portions of the file at once into memory so it does not use all the memory and stop other applications from running. However, it does make a temporary copy of the file to achieve this and this can take time for large files.

There are several options you can change to optimize the handling of large files. More information is available at our large file handling power tip.

我怎么可以移动我的配置设置到另一个系统?

The recommended way of doing this is by going to Advanced -> Backup/Restore User Customizations.

为什么帮助文件无效? 我去帮助- >索引,但是得到“页没被找到的”或“导航被取消的”错误。

Did you install UltraEdit to the network? If so, there is a known issue in which Windows will not display a compressed .chm (help) file when it is accessed across a network.

If you copy the .chm file (help file) to your local system, you should be able to access it.

我可以在UltraEdit里使用带HTML Tidy设置文件吗?

You can use a configuration file with HTML Tidy.

Version 11.00 and later:

Specify a configuration file before you run HTML Tidy (tidylib.dll) in the HTML Tidy dialog.

Prior to v11.00:

Edit the uedit32.ini file (normally in the %APPDATA%\IDMComp\UltraEdit directory) and under the [Settings] section add:

Html Tidy Config File="fully qualified filename in quotes"

This setting specifies the full path and filename of the configuration file to be used by HTML Tidy (htmltidy.dll). Normally this setting is not used and HTML Tidy uses the default configuration.

在UltraEdit里我在哪里可以找到语法高亮的附加wordfiles ?

Additional wordfiles as well as tag lists, auto complete files, and macros are available under Downloads.

我怎么可以打印语法高亮?

From the File menu, select "Print Setup/Configuration" and then "Page Setup". Here you will see an option to "Print Syntax Highlighting".

在展开“折叠全部”被折叠以后的外部文件夹,内在文件夹能保持折叠吗?

This is not currently possible with the "Collapse All" function. However inner-level folds are preserved when they have manually been collapsed within an outer-level fold.

我怎么可以迅速选择在UltraEdit里的文本大部分?

You can select large blocks with the Select Range dialog in the Edit menu. Additionally, here are a couple of methods for making this easier. If you position your cursor at the beginning of a block and move to the end of the block using the scrollbar and press Shift and then position your cursor appropriately the entire block will be selected.

Alternatively, you could position your cursor at the beginning of the block to be selected and, if there is unique text at the end of your block, you could do a Find. When you press Find Next, hold the Shift key and all text between the current cursor position and end of the found text will be selected.

我怎么可以删除包含特殊串的行?

You can replace lines containing a string with a Regular Expression Replace All. (Make sure "UltraEdit style Regular Expressions" are selected from the Adanced -> Configuration -> Search -> Regular Expressions Engine dialog.)

To do this you would do a find of:

Find What: %*YOUR STRING*^p
Replace With: (literally nothing)

The Regular Expressions section in the Help file has further details and examples are available online in the Power Tips section of our site.

UltraEdit为什么打开在十六进制模式下的有些文件?

When a file is loaded UltraEdit checks the first 7K of the file and if it contains more than two NULL (Hex 00) the file is considered a binary/HEX file. NULLS are not valid in an ASCII file and will be converted to spaces if you edit the file in text mode.

If you view a HEX file in text mode but make no changes UltraEdit should not convert the NULLS to spaces, but if you do make changes in TEXT mode to a HEX file the change will occur.

If you go to Advanced -> Configuration -> Editor -> Advanced and select "Allow editing of text files with HEX 00's ..." you should be ok. For UltraEdit prior v11.20 this setting is on the General tab toward the bottom under "Advanced/Problem Solving".

我怎么可以复制来自UltraEdit的十六进制值到规则ASCII文件?

You can use "HEX Copy Selected View" under HEX Functions in the Edit menu to do this

.

我怎么可以防止段落被用连字符号连接的词重新排版?

With the advanced menu enabled, please go to Advanced -> Configuration -> Editor Display -> Formatting and ensure that "Break on hyphen (-) when converting/reformatting paragraphs" is not selected.

我怎么可以去除在工具栏里的分隔线?

To remove the separators, drag the icon to the left of the separator over the separator.

我的文件Tabs消失了。当它们不再被显示,我怎么可以恢复打开文件Tabs?

The easiest way to bring back Open File Tabs is to go to View -> Views/Lists -> and select "Open File Tabs."

我怎么防止在4096个字节换行?

UltraEdit-32 does allow longer line lengths. Under the Advanced -> Configuration -> Editor Display -> Miscellaneous you can change the value of "Maximum columns before line wraps" to 20,000.

This setting sets the maximum columns allowed within UltraEdit before it wraps the line (soft wrap). The default is 4096 columns but a maximum of 20,000 is allowed. Some video drivers have a problem when this is set too high.

在UltraEdit里的规则为什么以0开始?

The ruler works as a normal ruler would, showing "0" as the start point, allowing the user to measure the number of columns prior to a given point. The status bar, on the other hand, is intended to show the column in which you're about to make an entry. As with normal Windows applications, both of these modes of indication and measurement are, I believe, the standard way of doing things, however, most applications do not include both.

If you prefer to have the ruler begin with "1" rather than "0" please go to Advanced -> Configuration -> Editor Display -> Miscellaneous and select "Start ruler numbering at column 1".

当UltraEdit保存一个文件时,我怎么防止UltraEdit 改变允许?

Please go to Advanced -> Configuration -> File Handling -> Advanced and select "Copy file instead of using rename when creating backup file".

我怎么关闭黄线?

The Active Line Background highlighting may be turned off under Set Colors in the View menu.

我为什么不可以增加词到拼写检查字典?

The "add" feature is only enabled if you have specified a custom dictionary to add the words to. In the spell checking dialog, click on "Dictionaries" and select a new file or add an existing file as the custom dictionary and this should work.

You can do this from the Advanced menu and Configuration also if you select the Spell Checker settings and select Dictionaries button.

You can't add words to the language dictionary provided, it is compressed. You have to create a new dictionary file with the NEW button or use an existing one.

我为什么不可以改变某些词的字体或大小在UltraEdit的一个文件?

To add different fonts and styles for different portions of the text would require that the font/style information be saved in the text file with the data. As a text editor, UltraEdit does not add any additional information to the file.

我在编辑和关闭在Ultraedit里的一个文件以后,为什么不可以删除目录或给目录改名?

When you use the File Open dialog to open a file it sets the current directory for the process to the directory you browse to. As this directory is now the current directory you cannot delete it. If you use the File Open dialog to browse to another directory you will be able to delete the previous directory.

为什么复制和粘贴有时中止工作?

UltraEdit supports multiple clipboards and sometimes users have activated one of the user clipboards without being aware of doing so.

The clipboards are activated from the Edit Menu, Right Click Menu or Ctrl+0 - Ctrl+9 with Ctrl+0 being the standard clipboard. The active clipboard is shown in the status bar following the line/col separated by a comma. C0 reflects the Windows Clipboard and C1-9 the user clipboards.

为什么在UltraEdit里ClearType字体不能显示?

There is an option under Advanced -> Configuration -> Editor Display -> Advanced that can help with the display of ClearType fonts. Please ensure that "Setting this may improve display issues with ClearType fonts on Windows XP" is selected.

如何用UltraEdit编译C#源程序?

1: 编译。

选取UltraEdit的菜单: 高级-〉工具配置

编译C# Console

命令行填:csc %n%e

工作目录:%p名称随意。

保存活动文件,输出到列表窗口,捕捉输出 这3个都选上。 最后点击 “插入“。

%P Path only ("C:\project\test\")

%N fileName only ("test")

%E Extension only (".c")

编译C# Console 有图标:

csc /win32icon:app.ico %n%e

编译C# dll:

csc /t:library /out:%n.dll %n%e

编译C# winexe:

csc /t:winexe %n%e

编译C# winexe有图标:

csc /t:winexe /win32icon:app.ico %n%e

然后,我的电脑-〉属性-〉高级-〉环境变量-〉Path 编辑为

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SystemRoot%\Microsoft.NET\Framework\v1.1.4322\

2: 关联。

高级-〉配置-〉文件关联

我使用的 : .cst ,文件描述:C#源文件 ,点添加即可。以后可双击直接打开.cst文件。 就是文本文件改后缀为.cst即可。

3: 上色。

高级-〉配置-〉语法着色 -〉语法文件全名

我的是 : D:\UltraEdit\WORDFILE.TXT 点打开。

找到/L7"C#" Line Comment = // Block Comment On = /* Block Comment Off = */

Escape Char = \ String Chars = "' File Extensions = CS

在后面加上CST/L7"C#" Line Comment = // Block Comment On = /* Block Comment Off = */

Escape Char = \ String Chars = "' File Extensions = CS CST

这样双击打开cst文件时就会自动加上C#语言的语法着色。

如何在UltraEdit中配置JAVA编译环境?

1.编译:打开高级--工具配置,在命令行下面输入javac %n%e,工作目录下输入%p ,在菜单项目名称下输入编译Java(可随意取名,只要自己喜欢),还有下面的checkbox中要选中保存活动文件,这样才在编译的时候先保存活动文件,在DOS命令输出下选中捕获输出,这样才可以看到结果!最后单击确定保存。

2.反编译:打开高级--工具配置,在命令行下面输入javap %n,工作目录下输入%p,在菜单项目名称下输入反编译Java,后面的设置同上。

3。运行:打开高级--工具配置,在命令行下面输入java %n,工作目录下输入%p ,在菜单项目名称下输入运行Java,后面的设置同上。

以上配置好后,就可以在高级菜单下看到有编译Java、反编译Java、运行Java三项了。当书写完一个.java文件后,或打开一个Java文件后,就可以运行这三个指令了。

%n,%p,%e等等是UltraEdit中的标识符,具体用法可以参见UltraEdit中的帮助以获得准确信息。

如何配置UltraEdit为Oracle PLSQL代码编辑器?

将下文复制到UltraEdit的wordfile.txt的最后,就能实现UltraEdit中对PL/SQL文件语法突出显示的支持。

具体步骤

1 打开菜单Advanced→Configration...,系统弹出一个窗口,

2 单击Syntax Highlighting标签,其中Full Path Name For下面的文件即为语法突出显示配置文件,

3 单击Open,即可在UltraEdit中打开该文件(wordfile.txt),将上文列出的PL/SQL语法配置脚本拷贝到该文件的最后面,

4 同时修改语法配置脚本文件的第一行,如果当前系统语法突出显示配置文件的最后一个为/L9,则将目前加入的PL/SQL修改为/L10,保存该文件。

至此,UltraEdit已经被配置成为Oracle PL/SQL代码编辑器。以后用户打开的所有以.sql为扩展名的文件,UltraEdit系统均认为是Oracle PL/SQL脚本,利用上面配置来突出显示其中的语法,程序看起来一目了然。
===========================================


/L8"PL/SQL" Nocase Line Comment = -- Block Comment On = /* Block Comment Off = */ File Extensions = SQL
/Delimiters = ~!%@^&*()-+=|\/{}[]:;"'<> , .?

/Function String = "%[A-Z _]*[~\s]+(*)"

/C1 "Keywords"

ABORT ACCEPT ACCESS ADD ALL ALTER AND ANY ARRAY ARRAYLEN AS ASC ASSERT ASSIGN AT AUDIT AUTHORIZATION AVG

BASE_TABLE BEGIN BETWEEN BINARY_INTEGER BODY BOOLEAN BY

CASE CHAR CHAR_BASE CHECK CLOSE CLUSTER CLUSTERS COLAUTH COLUMN COMMENT COMMIT COMPRESS CONNECT CONSTANT CRASH CREATE CURRENT CURRVAL CURSOR

DATABASE DATA_BASE DATE DBA DEBUGOFF DEBUGON DECLARE DECIMAL DEFAULT DEFINITION DELAY DELETE DESC DIGITS DISPOSE DISTINCT DO DROP

ELSE ELSIF END ENTRY EXCEPTION EXCEPTION_INIT EXCLUSIVE EXISTS EXIT

FALSE FETCH FILE FLOAT FOR FORM FROM FUNCTION

GENERIC GOTO GRANT GROUP

HAVING

IDENTIFIED IF IMMEDIATE IN INCREMENT INDEX INDEXES INDICATOR INITIAL INSERT INTEGER INTERFACE INTERSECT INTO IS

LEVEL LIKE LIMITED LOCK LONG LOOP

MAX MAXEXTENTS MIN MINEXTENTS MINUS MISLABEL MOD MODE

NATURAL NATURALN NEW NEXTVAL NOAUDIT NOCOMPRESS NOLOGGING NOT NOWAIT NULL NUMBER NUMBER_BASE

OF OFFLINE ON ONLINE OPEN OPTION OR ORDER OTHERS OUT

PACKAGE PARTITION PCTFREE PCTUSED PLS_INTEGER POSITIVE POSITIVEN PRAGMA PRIOR PRIVATE PRIVILEGES PROCEDURE PUBLIC

RAISE RANGE RAW REAL RECORD REF RELEASE REMR RENAME RESOURCE RETURN REVERSE REVOKE ROLLBACK ROW ROWID ROWLABEL ROWNUM ROWS ROWTYPE RUN

SAVEPOINT SCHEMA SELECT SEPARATE SESSION SET SHARE SMALLINT SPACE SQL SQLCODE SQLERRM START STATEMENT STDDEV SUBTYPE SUCCESSFUL SUM SYNONYM SYSDATE

TABAUTH TABLE TABLES TASK TERMINATE THEN TO TRIGGER TRUE TYPE

UID UNION UNIQUE UPDATE USE USER

VALIDATE VALUES VARCHAR VARCHAR2 VARIANCE VIEW VIEWS

WHEN WHENEVER WHERE WHILE WITH WORK WRITE

XOR

/C2 "Packages"

DBMS_OUTPUT

DBMS_JOB

DBMS_SQL

/C3 "Package Methods"

BIND_VARIABLE BIND_VARIABLE_CHAR BIND_VARIABLE_RAW BIND_VARIABLE_ROWID BROKEN

CHANGE CLOSE_CURSOR COLUMN_VALUE COLUMN_VALUE_CHAR COLUMN_VALUE_RAW COLUMN_VALUE_ROWID

DEFINE_COLUMN DEFINE_COLUMN_CHAR DEFINE_COLUMN_RAW DEFINE_COLUMN_ROWID DISABLE

ENABLE EXECUTE EXECUTE_AND_FETCH

FETCH_ROWS

GET_LINE GET_LINES

INTERVAL IS_OPEN

LAST_ERROR_POSITION LAST_ROW_COUNT LAST_ROW_ID LAST_SQL_FUNCTION_CODE

NEW_LINE NEXT_DATE

PARSE PUT PUT_LINE

REMOVE

SUBMIT

WHAT

/C4 "SQL*Plus Commands"

EXECUTE

GRANT

REPLACE

RUN

START

/C5 "SQL*Plus Functions"

ABS ADD_MONTHS ASCII

CEIL CHR CONCAT CONVERT COS COSH

DECODE

EXP

FLOOR

GREATEST

HEXTORAW

INITCAP INSTR

LAST_DAY LENGTH LN LOG LOWER LPAD LTRIM

MOD MONTHS_BETWEEN

NEXT_DAY NEW_TIME NLS_INITCAP NLS_LOWER NLS_UPPER NVL

POWER

RAWTOHEX REPLACE ROUND ROWIDTOCHAR RPAD RTRIM

SIGN SIN SINH SOUNDEX SQRT SUBSTR SUBSTRB

TAN TANH TO_CHAR TO_DATE TO_LABEL TO_MULTI_BYTE TO_NUMBER TO_SINGLE_TYPE TRANSLATE TRUNC

UPPER USERENV

VSIZE

/C6 "Should Be Reserved"

BEFORE

EACH

FOR

KEY

PRIMARY

WHEN WHERE WHILE

为什么不管安装什么版本ultraedit菜单一直都是德文?

这因为您不但要删除了安装目录还要删除配置文件。配置文件没有安装在安装目录下,它们在%appdata%\IDMComp\UltraEdit。

你能找到%appdata%目录,通过到(Windows菜单)开始: “Run %appdata%”,你能找到它IDMComp目录。

Ultraedit License是否只支持英文版本,我们怎么可以选择中文版本?

UltraEdit主要有以下语言版本: 英语,法语,德语,意大利语,韩语,简体中文、日语和西班牙语。对于这八种语言版本Licenses是通用的,并没有限制只能使用英文,不能使用中文等其它语言。

如何解决使用Ultraedit的SSH/Telnet 控制台登陆unix,查看中文时出现乱码?

Ultraedit V14.00及以下版本不支持中文,首先,确认是否使用Ultraedit V14.10以上的版本。然后按以下步骤操作:

1. Go to File -> FTP/Telnet -> SSH/Telnet Account Manager
2. Select the account that has the problem
3. Click on the "Terminal" tab (it is on the far right)
4. Click "Font Setup"
5. Select a font that will support Chinese characters. Also, make sure
the "Script" setting is correct for Chinese as well.

我在使用Ultraedit编译java源程序的时候,在编译完成后,运行完成后,在运行结果中中文显示出现了乱码,其他字符显示没错,请问该怎么解决?

请使用Ultraedit 14.10以上的版本。

Cnet/Download.com review
"我们并没有夸大其词:
UltraEdit真的非常棒..."

Corporate Licensing

It's easy to purchase corporate licensing from us!

  • Bulk/quantity discounts
  • Enterprise/plant/site licensing
  • Purchase with PO or invoice

The new UltraSuite

The only fully integrated solution of its kind!

Four powerful applications: UltraEdit, UltraCompare, UltraFinder, and UltraSentry!

Save over 33% when you bundle with the UltraSuite!

Power of Portable

Now supporting PortableApps!

UE/UC Mobile

Unleash the power of the total file management solution on your flash drive!