主页  »  技术支持  »  指南/使用技巧  »  UltraCompare  »  Quick text/code snippet compare
IDM Power Tips

Quick text/code snippet compare

With UltraCompare Professional you can now quickly compare code snippets without having to save your snippets into a file! So what does this mean for you?

Well, with UltraCompare Professional you can now copy and paste text from a variety of sources (emails, Word documents, webpages, etc.) and quickly note their differences. This feature will greatly enhance the efficiency of your diff checking, including:

  • Comparing text from word processor files
  • Quickly comparing local and remote HTML code
  • Comparing emails, or email composition changes
  • Comparing statistics or numbers
  • And much more!

Below we will be looking at how to use this convenient new feature.

Quick Text/Code Snippet Compare

To compare your code snippets, highlight the first section of code you would like to compare, then copy it.

Next, launch UltraCompare. If you are not already in text mode, select this from the "Mode" menu. Then click on one of the empty comparison panes and paste in your section of code, either using CTRL + V or right-clicking and selecting "Paste".

Compare Code Snippets

Hint: To turn on word wrap, go to View -> Toggle Word Wrap.

Repeat these steps for your second section of code, and paste them into the second pane. UltraCompare will immediately compare your two sections of code. If you have the Difference Summary enabled (in Options -> Configuration -> Application Layout), you will see this as well.

Compare Code Snippets

To clear the contents of a comparison frame, right-click anywhere in the comparison frame and select "Clear". Not only will your differences be cleared, but the temp files created by UltraCompare for the quick comparison will be permanently deletd as well.

Compare Code Snippets

Merge and Save Changes During Snippet Compare

What if you do not wish to permanently delete your snippet? UltraCompare Professional does provide the full range of merge options for your comparison environment, even while comparing snippets! Simply use the merge functions on your toolbar or between the comparison panes to make your changes.

Compare Code Snippets

Finally, save your result by going to File -> Save As...

Compare Code Snippets

Hint: for more information and a tutorial on merging in UltraCompare Professional, visit our Power Tip "UltraCompare Professional Block and Line Mode Merge".


Launch a Blank Comparison for Snippet Comparison from UltraEdit

Many users will prefer to launch UltraCompare from UltraEdit without having to select two files and set the compare options that are normally required when the "Compare Files" function is invoked.

UltraEdit provides you with an interface to do this via a custom tool configured to invoke UltraCompare from the command line. More information on configuring tools is available at our Power Tip Creating user and project tools.

You can then assign a custom icon to your UltraCompare tool. More information on this is available in our Power Tip Customizing the toolbar.


Back to power tips index


Buy Now
Upgrade
Download

还没有使用UltraCompare Pro?

Pro vs. Lite